52XUE Logo

好好学习,天天向上



Vue入门 :安装axios遇到的各种坑(超详细~)


问题描述

Vue项目中使用yarn add axios安装依赖报错:无法将“yarn”项识别为cmdlet、函数、脚本文件或可执行程序的名称。


解决方案

1. 分析原因,可能是没有安装yarn导致,所以执行命令:

npm install -g yarn

再执行yarn add axios发现依然报上述错误,不要慌不要慌,先记录一下yarn.js的路径备用,以笔者为例:C:\Users\Administrator\AppData\Roaming\npm\node_modules\yarn\bin


2. 再冷静分析一波,可能是yarn没有加入环境变量的原因。

可能有小伙伴还不怎么熟悉如何添加系统环境变量,以win10为例:此电脑 -> 属性 -> 高级系统设置 -> 环境变量 

在弹出的窗口中,拉到系统变量选择PATH一栏双击,点击添加,输入上一步记录的路径保存即可。


再执行yarn add axios发现不再报上面的错了,出现新的报错:PowerShell yarn : 无法加载文件C:\Users\Admin\AppData\Roaming\npm\yarn.ps1,因为在此系统因为在此系统上禁止运行脚本


3. 继续没啥说的,更改计算机执行策略吧,点击Win图标,搜索PowerShell,以管理员方式运行,在命令行中输入:

set-ExecutionPolicy RemoteSigned

再执行yarn add axios发现执行成功~


作者  :  超人会飞吗

天上地久有时尽,此恨绵绵无绝期。




about me

剪一束月光

秋风清,秋月明。
落叶聚还散,
寒鸦栖复惊。
相思相见知何日,
此时此夜难为情。

联系站长

热门标签